Unable to add published apps icons in the endpoint’s Desktop

Unable to add published apps icons in the endpoint’s Desktop

book

Article ID: CTX282556

calendar_today

Updated On:

Description

  • The customer is installing CWA1912 in multiple endpoint machines running Windows 7 for one of his clients
  • He is using a 3rd party tool to install CWA via CLI massively.
  • He is pushing the StoreFront Store via GPO and not through the installation command.
  • He already installed CWA in some machines and applied the GPO but the published icons are not showing up in the Desktop

Resolution

  1. Uninstalled CWA from the endpoint
  2. Confirmed the ‘User Subscription’ is set to ‘mandatory mode’ in the Store settings through the StoreFront console
  3. Confirmed ’Manage SelfServiceMode’ policy was set to ‘disabled’
  4. Configured the ‘Manage App shortcut’ policy and ticked ‘Enable Desktop Shortcut’
  5. Removed the ADDLOCAL switch from the installation command and installed CWA using only:
<CitrixWorkspaceApp.exe /silent /includeSSON /forceinstall ENABLE_SSON=Yes>

Note: in this scenario the StoreFront account is being pushed using GPO

Problem Cause

The ‘Manage App shortcut’ policy was not configured and the installation command had a wrong switch (ADDLOCAL).

Additional Information

https://support.citrix.com/article/CTX201261
https://support.citrix.com/article/CTX200924