Error: "Cannot complete your request" when login to the Storefront with SAML.

Error: "Cannot complete your request" when login to the Storefront with SAML.

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Article ID: CTX282546

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Updated On:

Description

While login to the Storefront with SAML authentication getting "Cannot complete your request"

Storefront error : 

Event ID 6
CitrixAGBasic single sign-on failed because the supplied domain: domain.com  is invalid. This has two main causes, either;

The single sign-on domain specified in the session profile on the gateway must be blank for SAML UPN auth.

or

If the domains are being restricted in the StoreFront console, then the domain: domain.com is not present in the list of Trusted Domains.

Resolution

  1. Login to the storefront.
  2. Select the store name.
  3. Select Manage Authentication Methods from Actions Pane.
  4. Select Settings and Configure Trusted Domain from User name and Password method.
  5. Add the new domain into Trusted Domain list.

Problem Cause

User domain not added into Trusted Domain List