Citrix WEM Agents not Synchronizing Error “No Connection Could be Made Because The Target Machine Actively Refused it”

Citrix WEM Agents not Synchronizing Error “No Connection Could be Made Because The Target Machine Actively Refused it”

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Article ID: CTX282435

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Updated On:

Description

Citrix Virtual Delivery Agents running Workspace Environment Management (WEM) Agents are not synchronizing with two or more WEM Broker servers load balanced via Citrix Gateway. 

  • Policies delivered through WEM are not applying to agents 
  • Event Viewer shows the following error: “No connection could be made because the target machine actively refused it …”

Resolution

Create a new virtual server for Data Synchronization over port 8288 in Citrix Gateway. Please review the following link for additional information and detailed steps on how to create it: 
  • https://docs.citrix.com/en-us/workspace-environment-management/current-release/reference/load-balancing-with-citrix-adc.html 

Problem Cause

Data synchronization Server for port 8288 was not created in the Citrix Gateway Load Balance setup. 

Additional Information

https://docs.citrix.com/en-us/workspace-environment-management/current-release/reference/load-balancing-with-citrix-adc.html