Uploading Enterprise App (Private App) to Google Play Store via Cloud Endpoint Management Fails - Error "Upload a new APK file with a different package name"

Uploading Enterprise App (Private App) to Google Play Store via Cloud Endpoint Management Fails - Error "Upload a new APK file with a different package name"

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Article ID: CTX279402

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Updated On:

Description

Uploading an APK file to Managed Google Play Store as instructed in Citrix Documentation you receive the following error message: 

  • "Upload a new APK file with a different package name "

 

Resolution

  1. Login to the Google developer account that is associated with this Cloud Endpoint Management Site.
  2. Look for the app releases page
    • There is a section on uploading APKs
  3. Try and upload the APK
    • If the upload fails, the console will reveal a more detailed error message of the cause


Review the error provided and confirm the APK is valid. Open a case with Google if problem persists. 


Problem Cause

The package name already exists in the Google Play Store. The error is coming from the Google Play Store not from Citrix Cloud Endpoint Management.

Issue/Introduction

When you try to upload a private app to the google play store you get this error