"An RDS Licensing mode has not been configured by the License Server with the Per User Client Access RDS Licensing type" warning on Citrix Cloud Monitor

"An RDS Licensing mode has not been configured by the License Server with the Per User Client Access RDS Licensing type" warning on Citrix Cloud Monitor

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Article ID: CTX277472

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Updated On:

Description

On Citrix Cloud Monitor (Director) for a session's Machine Details section under Microsoft RDS License field we see a License Error. 

 

When the mouse is hovered over it, we see a message "An RDS Licensing mode has not been configured by the License Server with the Per User Client Access RDS Licensing type".

Resolution

Ensure that the RDS License Server is configured properly through GPO on the VDAs as per CTX238259 . You can run RSOP to verify that it is being applied. 

 

If the configuration is correct, check the following registry entry:

Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\Licensing Core

Key: LicensingMode

 

The DWORD value needs to be 4 (if using Per User licenses) or 2 (if using Per Device Licenses)

 

If you find the value to be 5, change it to either 4 or 2 and start a new session to the VDA. A reboot is not usually required.


Problem Cause

Incorrect registry entry for RDS Licensing Mode on the VDA.