VA VD 1912 CU1 : Firefox browser unable to detect workspace 1912
book
Article ID: CTX275246
calendar_today
Updated On:
Description
Firefox browser does not automatically detect Citrix Workspace
Resolution
SERVER SIDE CHANGES :
For StoreFront deployments, modify web.config under the Receiver for Web (RfWeb) site (typically C:\inetpub\wwwroot\Citrix\StoreWeb) to activate the Citrix Receiver Launcher / Citrix Workspace App Launcher for Firefox and other browsers. 1. Open web.config using your preferred text editor and locate the line : 2. The value of the platforms attribute is a regular expression specifying the browsers that Citrix Receiver Launcher is used for client detection and HDX launches. Change the regular expression to: "(Macintosh|Windows NT).*((Firefox/((5[2-9]|[6789][0-9])|\d\d\d))|(Chrome/((4[2-9]|[56789][0-9])|\d\d\d)))|Macintosh.*Version/(1[2-9]|[2-9][0-9]).*Safari/" 3. This will add all versions of Firefox and all other browsers to the list of browsers that Citrix Receiver Launcher will be used.
On the client machine: -- Delete the browser cache and history and test the issue while browsing store URL resolved
Problem Cause
Issue with workspace not determining latest firefox browsers
Was this article helpful?
thumb_up
Yes
thumb_down
No