HDX session may stop responding and hang if endpoint device has unusable printer
                    
                
                
                    
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Article ID: CTX270308
                        
                    
                    
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Updated On: 
                    
                 
                
                    
                
                    
                    
                        
                            
Description
                        
                        
                            Citrix HDX session may stop responding and hang if endpoint device has unusable printer.
                         
                     
                    
                    
                    
                    
                        
                            
                                
Resolution
                            
                            
                                To avoid this problem, do either of the following:
- Remove unusable printer from the endpoint device.
- Set the Auto-create client printers policy to "Do not auto-create client printers" or "Auto-create the client's default printer only". You can set it to "Auto-create local (non-network) client printers only" if the unusable printer is a network printer.
Problem Cause
When creating client printers, Citrix Print Manager Service sends requests to get printer properties to Receiver/Workspace app over the virtual channel. After receiving it, Receiver/Workspace app attempts to get the printer properties by querying the printer drivers. However, the client process may take a long time to return or never return if the printer is unusable, which can lead to a hung session. This is a limitation of current design. 
                            
 
                        
                    
                    
                    
                    
                
                    
                        
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