Upgrade of VDA fails on PvD component

Upgrade of VDA fails on PvD component

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Article ID: CTX269199

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Updated On:

Description

Applicable Products:

VDA version 1912 and later 

Description:

Upgrade of the VDA to version 1912 LTSR or later stops with an error: “The PvD component install or upgrade is not supported. For more information, see CTX269199”

Root cause:

If the Personal vDisk (PvD) component was ever installed on a VDA, that VDA cannot be upgraded to version 1912 LTSR or later. (This applies even if you installed PvD but never used it.) To upgrade to the new VDA version, you must manually uninstall the existing VDA and then install the new VDA.

Learn if you’re affected:

How PvD might have been installed in earlier versions:

  • In the VDA installer’s graphical interface, PvD was an option on the Additional Components page. The 7.15 LTSR and earlier 7.x releases enabled this option by default. So, if you accepted the defaults (or explicitly enabled the option in any release), PvD was installed.
  • On the command line, the /baseimage option installed PvD. If you specified this option, or used a script that contained this option, PvD was installed.

If you don’t know whether your VDA has PvD installed, run the installer for the new VDA (1912 LTSR or later) on the machine or image.
  • If PvD is installed, a message appears, indicating there is an incompatible component.
  • For the graphical interface, click Cancel on the page containing the message, and then confirm that you want to close the installer.
  • From the CLI, the command simply fails with the displayed message.
  • If PvD is not installed, the upgrade proceeds.

Resolution

  1. Exit the VDA upgrade.
  2. From the Control Panel, access Programs and Features.
  3. Right-click the Citrix Virtual Delivery Agent entry and select Uninstall.
  4. Reboot the VDA machine after the uninstall process completes.
  5. Restart the new (version 1912 or above) VDA deployment.

Additional Information

If the uninstallation encounters a problem, try using the VDA cleanup utility.
https://support.citrix.com/article/CTX209255