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Article ID: CTX269160
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Updated On:
Description
When launching a virtual application/desktop using the Citrix Workspace app for HTML5, there is a silent failure to launch.
Resolution
The Admin would need to navigate to Delivery group > Edit delivery group > User settings > Uncheck "Enable SecureICA"
Problem Cause
SecureICA is not supported on the Citrix Workspace app for HTML5.
Note: SecureICA does not use FIPS-compliant algorithms. SecureICA does not perform authentication or check data integrity.
- If SecureICA is enabled via default.ica, there is a fallback to Basic encryption and end-users will not see an impact.
- If SecureICA is enabled via the Delivery Group settings, the users will see launch failures for both virtual apps and desktops.
To confirm this is the root cause,
- you can access console logs for the Citrix Workspace app for HTML5 as per instructions at: https://support.citrix.com/article/CTX217352.In the .txt file generated, you will be able to see
“SESSION:|:ICA:|:WINSTATION:|:DRIVER:|:terminate session5" - Alternately, on the VDA you can see events inside System event viewer >Source "TDICA" > "ICA transport driver connection closed"
- Or on the DDC (Cloud connector in case of Citrix cloud-hosted environment) > event viewer >administrative events > Source "Schannel" > A fatal error occurred while creating a TLS client credential
Recommended alternative: If you’d like an alternative to SecureICA, we recommend you use TLS (Transport Layer Security). For more information on TLS, see
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/secure/tls.html.