Workspace App for Windows shows "Fatal error during installation" while launching applications.

Workspace App for Windows shows "Fatal error during installation" while launching applications.

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Article ID: CTX267718

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Updated On:

Description

Note: this article is intended for Citrix administrators and technical teams only. Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

After an .ica file has been downloaded during a launch attempt from browser, the following messages appear on the screen.

"Please wait while Windows configures Online Plug-in"


"Fatal error during installation"


An error message such as below might be logged in Event Viewer on the endpoint machine:
"MsiInstaller",1001,"Detection of product '{51059DCA-191F-49CD-8A37-FE5516EA52C9}', feature 'WEB_CLIENT' failed during request for component '{1762F5BA-3F32-4A41-90CB-83C447BE6ED2}'"

Resolution

  1. Re-install Citrix Workspace app on the affected machine.
  2. If the issue persists, check the existing file association for the .ica format.
    • Start Command Line as Administrator and execute the following command:
      assoc .ica
    • Copy the part of the output after ".ica =" and run the ftype command against it, e.g.: 
      ftype Citrix.ICAClient.2.16
  3. Check if wfcrun32.exe is present in the location that was returned by the above command.
  4. If the path is correct, create a new file type association for .ica by executing the below command. 
    ftype Citrix.ICAClient.2.16.NEW="C:\Program Files (x86)\Citrix\ICA Client\wfcrun32.exe" "%1"
    assoc .ica=Citrix.ICAClient.2.16.NEW

Problem Cause

.ICA file association might have become corrupted on the machine, even if it appears intact in registry.