Failed to launch session with the error code “Your session <AppName> did not launch successfully due to error code 3501. Please contact your administrator for more information about the error.” on Citrix Workspace App During App/Desktop Launch

Failed to launch session with the error code “Your session <AppName> did not launch successfully due to error code 3501. Please contact your administrator for more information about the error.” on Citrix Workspace App During App/Desktop Launch

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Article ID: CTX267694

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
 
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.



When launching an application or desktop session using Citrix Workspace App, the session fails to launch with the error code “Your session 'AppName' did not launch successfully due to error code 3501. Please contact your administrator for more information about the error.”

Resolution

For Static virtual Desktops:
Plesae add sufficient number of machines to the machine catalog.
 
For Citrix Virtual Apps published apps:
By default, there is no limit on how many application instances can run at the same time. If you configured any of the following application limit, please adjust the setting based on your requirement:
Note: If more than one limit is configured, this error is reported when the first limit is reached.
  1. The maximum number of concurrent instances of the application by all users in the Delivery Group.
This can be configured on Citrix Studio -> Applications -> <YourApplication> ->property -> Delivery -> Limit the number of instances running at the same time to:

 
  1. One instance of the application per user in the Delivery Group.
This can be configured on Citrix Studio -> Applications -> <YourApplication> ->property -> Delivery -> Limit to one instance per user

 
  1. The maximum number of concurrent instances of the application per machine.
This can be configured by PowerShell only:
Set-BrokerApplication -Name <yourapplication> -MaxPerMachineInstances <number>

You can also check if you have any of above configured by following PowerShell cmdlet:
asnp Citrix.*
Get-BrokerApplication -name <YourApplicationName> |Select max*
 

You can verify the application instances running by following PowerShell cmdlet:
asnp Citrix.*
(Get-BrokerSession -ApplicationInUse <yourapplicationname> -MaxRecordCount 10000).count

Problem Cause

  • For Static virtual Desktops, there is no sufficient machines in the Delivery Group for the user to connect to.
  • For Citrix Virtual Apps published apps, the limit on how many application instances can run at the same time is reached.

Additional Information

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/manage-deployment/applications-manage.html#configure-application-limits