Failed to launch session with the error code “<AppName> is no longer available. Do you want to remove the shortcut?” on Citrix Workspace App during App/Desktop Launch

Failed to launch session with the error code “<AppName> is no longer available. Do you want to remove the shortcut?” on Citrix Workspace App during App/Desktop Launch

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Article ID: CTX267691

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Updated On:

Description

When a user tries to launch published application or Desktop by double clicking the shortcut of published applications or Desktops created on user’s Desktop or Start menu, launch fails with error “'AppName' is no longer available. Do you want to remove the shortcut?”

Note:
This error only applies to XenApp PNAgent site.
This error applies to all methods to create shortcuts on user’s Desktop or Start menu mentioned in Citrix Workspace app for Windows documentation.
 

Resolution

If Citrix Workspace app Self-Service Plug-in is disabled by Manage SelfServieMode policy
  • Right click the Citrix Workspace app icon in Windows notification area and click Refresh.
If Citrix Workspace app Self-Service Plug-in is enabled
  • Open Citrix Workspace app, click the user name, in the dropdown list, and click Refresh Apps.
By doing either of above, Citrix Workspace app will clean up the shortcuts no longer available for the user.

Problem Cause

The error occurs because while the user is still logged into Citrix Workspace app, the published application or Desktop is set to not available to the user anymore.
The published application or Desktop that is no longer available to the user can be caused by following configuration changes:

For published application:
  1. The application is not published anymore: You can go to Citrix Studio -> Applications and verify if the application is listed.
  2. The application is disabled: You can go to Citrix Studio -> Applications -> <your application> and verify if state is disabled.
  3. The user no longer belongs to the users and groups of Limit visibility for this application: You can go to Citrix Studio -> Applications -> <your application> -> Properties -> limit Visibility and verify if the user is included.
  4. The Delivery Group to publish the application is no longer assigned to the user: You can go to Citrix Studio -> Delivery Groups -> <your Delivery Group> -> Edit Delivery Group -> Users and verify if the user is included.
  5. The Delivery Group is deleted: You can go to Citrix Studio -> Delivery Groups and verify if the Delivery Group exists.
For published Desktop:
  1. The user can no longer launch the desktop in the Delivery Group: You can go to Citrix Studio -> Delivery Groups -> <your Delivery Group> -> Edit Delivery Group -> Desktops and verify if the user is included.
  2. The Delivery Group to publish the Desktop is no longer assigned to the user: You can go to Citrix Studio -> Delivery Groups -> <your Delivery Group> -> Edit Delivery Group -> Users and verify if the user is included.
  3. The Delivery Group is deleted: You can go to Citrix Studio -> Delivery Groups and verify if the Delivery Group exists.