Explorer is crashing consistently on the VDA after installing updates or applications

Explorer is crashing consistently on the VDA after installing updates or applications

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Article ID: CTX264843

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Updated On:

Description

Please consider below symptoms:

  • The master image or vDisk was recently updated.
  • After rolling out the image to production the Explorer starts crashing consistently.
  • There may be other processes that may be crashing as well.
  • Creating below registry to exclude the process from loading citrix hooks fixes the issue:

Key: HKLM\SYSTEM\CurrentControlSet\services\CtxUvi
Value Name: UviProcessExcludes
Type: REG_SZ
Value: Explorer.exe

Ref: https://support.citrix.com/article/CTX107825 

Resolution

To resolve this problem, the path variable needs to be checked under the system environment variable. Please follow the steps below to check the same:
 
  1. On the Start menu, right-click Computer.

  2. On the context menu, click Properties.

  3. In the System dialog box, click Advanced system settings.

  4. On the Advanced tab of the System Properties dialog box, click Environment Variables.

  5. Under the System Variables, please check the Path as shown below

 

If the Entry “C:\Program Files (x86)\Citrix\System32\” is missing as shown above, please add the same by clicking on new.


Problem Cause

The Explorer.exe crash may be caused due to a Missing Entry – “C:\Program Files(x86)\Citrix\System32\” in “Path” Variable under System Environment variables. This lead to the delayed loading of the Citrix Hook – “ctxwsapi64.dll”, which causes the crash of the Explorer.