Citrix Licensing: Studio unable to connect to Licensing server - Untrusted server

Citrix Licensing: Studio unable to connect to Licensing server - Untrusted server

book

Article ID: CTX263623

calendar_today

Updated On:

Description

1. Unable to connect to Citrix Licensing server from Studio getting "Untrusted server".
2. Getting "An error occurred while retrieving the certificate for the license server at this address".
3. Error Id: XDDS:BD69C800
DesktopStudio_ErrorId : UnknownError ErrorCategory : ResourceUnavailable DesktopStudio_ErrorId : CommunicationError Sdk Error Message : CommunicationError Sdk
Error ID : Citrix.PowerShell.LicensingAdminStatus.CommunicationError,Citrix.Licensing.Admin.SDK.Commands.GetLicCertificateCommand
ErrorCategory : ResourceUnavailable DesktopStudio_PowerShellHistory : Get the certificate for the Licensing Service

Resolution

Open port 8083 between Controllers and License Server.
Port 27000, 7279, 8082 and 8083 are required to connect to Citrix license server.

Problem Cause

Port 8083 was blocked between the Controller and License Server

Additional Information

Citrix Communication Ports: https://support.citrix.com/article/CTX101810