How To Troubleshoot And Fix The Situation When The ADM HA Is Not Working

How To Troubleshoot And Fix The Situation When The ADM HA Is Not Working

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Article ID: CTX261991

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Updated On:

Description

One of the possible error conditions reported in the deployment is where in the GUI System -> Deployment the following symptoms are reported: 

Heartbeats are not received from the secondary
Data synchronization has failed on secondary


Apart of the information displayed in GUI on primary node, there may be the following further observations: 
- the secondary node is not running 
- the secondary node is running, but mas_hb_monit process is not running 

Resolution

-    if the file /mpsconfig/mas_hb_monit.conf is corrupted – manually fix the values
-    if the file /mpsconfig/mas_hb_monit.conf is missing – copy the file from /mps/mas_hb_monit.conf and manually fix the file 

To recover the values from mas_hb_monit.conf, the file /mpsconfig/mas_hb_monit.tmp may be used. Usually it is necessary to only fill 2 values: 
-    peer_ip
-    virtual_ip_alias
 

Problem Cause

The most probable causes are related to the file /mpsconfig/mas_hb_monit.conf: 
- the file is corrupted 
- the file is missing
 

Issue/Introduction

This article helps to troubleshoot and fix one of the possible fault situations related to Citrix ADM HA.

Additional Information

CTX261729 - Processes, Logs And Configuration Files Participating in Citrix ADM High Availability