Error "Installation of Smart tools agent failed with error code 1619" seen while upgrading DDC from 7.15 CU3 to 7.15 CU4.

Error "Installation of Smart tools agent failed with error code 1619" seen while upgrading DDC from 7.15 CU3 to 7.15 CU4.

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Article ID: CTX261944

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Updated On:

Description

Error "Installation of Smart tools agent failed with error code 1619" seen while upgrading DDC from 7.15 CU3 to 7.15 CU4.

or

XenDesktopServerSetup has stopped working.   Unhandled Exception: System.ComponentModel.Win32Exception: The system cannot find the file specified.

or

Installing from CU4 media shows the CU3 installer

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Remove the following Registry Key if found:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce\!XenDesktopSetup

Remove the following folder if present:

C:\ProgramData\Citrix\XenDesktopSetup

Re-run the installer.

Problem Cause

These elements are artifacts from a previous installation that should have been removed/cleaned up but were not for unknown reasons.  Citrix has been unable to reproduce this behavior internally.  

Issue/Introduction

DDC Upgrade Issues