ADC 12. - VIP marked down. Error on service monitor "Timeout during TCP connection establishment stage"

ADC 12. - VIP marked down. Error on service monitor "Timeout during TCP connection establishment stage"

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Article ID: CTX261812

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Updated On:

Description

* Users unable to access the VIP from client machines.
* On ADC GUI VIP is marked as down.
* Monitor status shows "Timeout during TCP connection establishment stage"

Resolution

Allowed the communication on firewall from SNIP to the backend server on specified port

Problem Cause

TCP handshake failed as communication was not allowed on firewall. 

Issue/Introduction

.

Additional Information

The monitor message "Time out during TCP connection establishment stage" means that the web server either was not listening or was unreachable. This indicates a network problem. 

In this case it was a firewall misconfiguration where a rule was causing the issue. After the rule was modified to allow tcp connections, it worked and service came up.

Make sure that we have connectivity between the SNIP and the backend server IP.

Other probable reasons : https://support.citrix.com/article/CTX108960