Storefront Cannot Complete your request through a Load Balancer
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Article ID: CTX261738
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Updated On:
Description
Direct to Storefront works without issue.
However, direct connection to a Load Balancer, even with one server on the backend, fails with Cannot Complete your Request immediately before prompting for authentication.

In a trace, you will see a POST to /Citrix/StoreNameWeb/GatewayAuth/Login. It is this URL that identifies the incorrect Authentication method was chosen due to the incorrect Storefront configuration.
Resolution
If you have configured the "VServer IP address (optional)" setting at Storefront->Stores->Manage Citrix Gateways->Edit each Gateway configured.
For each Gateway, select "Authentication Settings" and check the "VServer IP address (optionsl)" field. Ensure it is blank in each of your configured Gateways.

Problem Cause
When the "VServer IP address (optionsl)" field contains an IP address, then Storefront will assume any traffic from that Source IP is a Gateway, and thus will present the Gateway Auth login method. This is not what you want if you are simply load balancing Storefront, so you need to ensure the field is blank.
Issue/Introduction
Storefront with a Load Balancer returns cannot complete your request immediately upon accessing the page.
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