Windows 10 v2004, 20H2, 21H1, 21H2 & 22H2 – Citrix Known Issues

Windows 10 v2004, 20H2, 21H1, 21H2 & 22H2 – Citrix Known Issues

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Article ID: CTX255870

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Updated On:

Description

Microsoft releases software updates for Windows 10 twice a year through the Semi-Annual Channel. Microsoft released its Semi-Annual Channel 'May 2020 update' (v2004) in May 2020, 'October 2020 update' (20H2) in October 2020, 'May 2021 update' (21H1) in May 2021, 'November 2021 update' (21H2) and '2022 Update'.

This article is intended to capture known issues with Windows 10 v2004, 20H2, 21H1, 21H2, and 22H2 that have been identified so far through Citrix internal testing and customer reports.

Note:

  • This is a live article and is updated as and when new information is available.
  • Unless explicitly specified, issues seen with Windows 10 v2004 are seen with 20H2, 21H1 & 21H2 also.
 

Known Issues

The following are the known issues:  

Issue 1

Issue Description
Citrix User Profile Manager (UPM) may stop working after Windows 10 with VDA installed is upgraded to v2004 OR it may break the native Windows applications like notepad, calculator etc when UPM is configured on fresh install of v2004.

[TPV-2706]

Problem Cause
Changes in Windows 10 v2004 are causing this issue.

Solution
This issue is fixed in Citrix Virtual Apps and Desktops 7 2003 and later versions.

 

Issue 2

Issue Description
Printers part of Citrix Universal Print Server (UPS) are not mapped within ICA session of Windows 10 v2004 VDA.

Problem Cause
Changes in Windows 10 v2004 Operating System is causing the printer mapping failure.

Solution
This issue is resolved with the Microsoft Defender Advanced Threat Protection signature updates released around June 2020.


Issue 3

Issue Description
On Virtual Machine's (hosted on vSphere) with VM version 14 and boot option EFI, a failure may be seen when you upgrade Windows 10 machine to v2004 with an error “We can’t tell if your PC is ready to continue installing Windows 10. Try restating the setup”

[TPV-2703]

Solution
Installing the latest VMWare tools 11.0.0.x before attempting to upgrade to v2004 resolves this issue.
 

 

Issue 4

Issue Description
On Windows 10 v2004 end point with Receiver/Workspace App, when a network interruption is caused by disabling the Network Interface from Control Panel, Session Reliability feature fails to work.
[RFWIN-15116]

Problem Cause
Changes in Windows 10 v2004 Operating System is making the Session Reliability to fall back to Auto Client Reconnect when the network is disrupted. 

Solution
This issue has been fixed in Citrix Workspace App.

  • Users on Current Release of Workspace App are advised to upgrade to version 2002 or its replacement that contains the fix.
  • Users on the LTSR version of Workspace App are advised to upgrade to version 1912 or its replacement that contains the fix.

 

Issue 5

Issue Description
On Windows 10 v2004 end point with Receiver/Workspace App, when a network interruption is caused using Firewall, Session Reliability feature fails to work.
[RFWIN-15263]

Problem Cause
Changes in Windows 10 v2004 Operating System is making the Session Reliability to fall back to Auto Client Reconnect as soon as the the network is disrupted.

Solution
This issue has been fixed with KB4571744. Install this KB OR its replacement on end-points to resolve this issue.


Issue 6

Issue Description
ICA launch of Citrix VDA installed on Windows 10 Virtual Desktop v2004 fails OR ICA session disconnects within 2 minutes with error message “Idle Timer Expired “ or “Logon timer Expired”.
[TPV-3025]

Problem Cause 
Changes in Windows 10 v2004 Operating System is causing this issue.

Solution
For Citrix VDA version 2006 and above:
Issue is resolved in KB4586853,  Install this KB OR its replacement on your VDAs to resolve this issue.

For Citrix VDA versions before 2006: 
ICA launch still fails and Citrix is working on fixing it. Please use the below workaround. 

Workaround
The WDDM graphics display driver for Remote Desktop Connection which is enabled by default in Windows 10 v2004 and above needs to be disabled as it is not supported by the Citrix VDA. To disable, set the below policies through the group policies for your OU:

  • Browse to Administrative Templates (Computers) -> Windows Components - > Remote Desktop Service -> Remote Desktop Session Host.
  • Disable the setting “Use WDDM graphics display driver for Remote Desktop Connection”

 

Issue 7

Issue Description
A failure during component initialization may be seen when 7.15 LTSR VDA (with any CU) is upgraded to CU6 on Windows 10 v2004. This issue is not seen with a fresh install of CU6 VDA on Windows 10 v2004.
[LCM-7909]

Problem Cause
An error "Failed to configure component 'ICA for workstation services' because it is not installed" is seen. Changes in Windows 10 v2004 is causing this issue.

Solution
Citrix is working with Microsoft to resolve this issue.

Workaround

  • Uninstalling the existing CU and installing CU6 resolves this issue.
  • Upgrading 7.15 LTSR VDA to CU6 prior to upgrading VDA OS to Windows 10 v2004 is advised.


Issue 8

Issue Description
Following upgrade to Windows 10 v2004, user personalization layer (UPL) services will no longer be able to start during logon. This prevents user layer disks from attaching or being created when users log into their desktops. Note, this issue does not impact App Layering User Layers, it only affects user personalization layer for Virtual Apps and Desktops
[UNI-78456]

Problem Cause 
During upgrade to Windows 10 v2004 Microsoft is removing the UPL service key and service from the Winlogon chain.

Solution
This issue is fixed in Citrix Virtual Apps and Desktops 2009 or newer. This issue has also been fixed with the latest updates of 20H1/20H2.
 

Issue 9

Issue Description
App Layering fails to import a new OS Layer for Windows 10 v2004 with the error: “A failure occurred while importing the OS: Cannot handle more than two partitions on a disk.”
[UNI-79067]

Problem Cause 
Importing Windows 10 v2004 as a new OS Layer fails due to Windows creating a recovery partition during installation which results in their being a total of three partitions for the image. This is greater than the maximum two partitions allowed for OS Import.

Solution
This issue is fixed in Application Layering 2009 or newer. Citrix recommends to upgrade the Enterprise Layer Manager (ELM) and do the import again.

 

Issue 10

Issue Description
Published images from App Layering running Windows 10 v2004 can take 5 minutes or longer to log into Windows and/or for the Start Menu to appear after login.
[UNI-79147]

Problem Cause 
The issue is caused by missing dependencies between the App Layering uniservice, and the Windows Delivery Optimization Service (dosvc) and Storage Service (StorSvc).

Solution
This issue is fixed in Application Layering 2011 or newer. Citrix recommends to upgrade the Enterprise Layer Manager (ELM) and redeploy any images.


Issue 11

Issue Description
Audio redirection may fail after a reconnect of ICA session on Windows 10 Multi-session editions with Citrix VDA.
[CVADHELP-15804]

Problem Cause 
Changes made in Windows 10 v2004 is causing this issue.

Solution
This issue is fixed in Citrix Virtual Apps and Desktops 2106 or newer AND 1912 CU3 or newer.
 


Issue 12

Issue Description
Upgrade to Windows 10 20H2 OR 21H2 may fail on machines that are configured to have domain administrator profiles managed by UPM

[UPM-3083]

Problem Cause 
Changes made in Windows 10 v2004/21H2 is causing this issue.

Solution
There is no solution. Citrix is working with Microsoft to resolve this issue.

Workaround
Ensure the domain administrator profiles are not managed by UPM before upgrading to Windows 10 20H2 Or 21H2.
 

 

Issue 13

Issue Description
Following an upgrade to Windows 10 21H1, images running user personalization layer (UPL) will exhibit Start Menu issues, and users will be prompted to reboot the image to fix this issue. Rebooting the image will not fix it.
[UNI-83300]

Problem Cause 
During upgrade to Windows 10 21H1 Microsoft is removing a Uniservice dependency for login services.

Solution
Solution is available in a VDA (UPL) upgrade using any one of the following versions (or higher):
CVAD 2206, CVAD 2203 LTSR CU1, or CVAD 1912 LTSR CU6 

Workaround
When authoring the master image which was upgraded to Windows 10 21H1, the VDA can be uninstalled and reinstalled (including UPL) to resolve the issue.



Issue 14

Issue Description

"The trust relationship between this workstation and the primary domain failed" error occurs after MCS VDAs are upgraded from an earlier version of Windows 10.

Problem Cause

The dependency of "Citrix Pvs VMs agent" service is lost by the upgrade. 

Solution
This issue has been resolved by Microsoft. The resolution can be obtained in one of the following ways:

  • If upgrading to newer Windows version though Windows Update, no action is necessary as the upgrade would contain the fix.
  • If using an ISO to upgrade, one has to choose option 'Download updates, drivers and optional features (recommended)' during the upgrade process for installer to get the fix.
  • If using an ISO, and for any reason, cannot choose 'Download updates, drivers and optional features (recommended)', the fix would need to be downloaded from Microsoft and included into the ISO of the new Windows version intended to be upgraded to. Follow the steps below:

The Windows update listed below have the fixes for the issue and are available as cab files.

Windows 10 (VB releases), KB 5020377, Servicing release 2022.11C
https://www.catalog.update.microsoft.com/Search.aspx?q=KB5020377 

Method of installing these updates into your systems: 

  • Download the above .cab file and extract the files using the ‘expand’ command available in Windows shell.
  • Replace the acmigration.dll and appraiser.sdb in the targeted OS installation media with these files from the extracted cab file  (ignore if acmigration.dll is not present)  and run the OS upgrade. 

Follow steps below:

  • Downlaod and copy the cab file to a local folder (eg c:\temp) in your windows machine 
  • Open command prompt as an administrator and run the following commands
Cd c:\temp
Expand -f:*  windows10.0-kb5020377-x64_aa63fed981cc761dd28de9e0a0a204f6b7003d23.cab c:\temp 
  • The above operation extracts the contents of the cab file to c:\temp folder. 
  • Open the c:\temp folder and copy two files named “acmigration.dll and appraiser.sdb”.
  • Mount and copy the contents of targeted OS installer to a local folder (eg c:\os )
  • In the “sources” folder replace the acmigration.dll and appraiser.sdb files in the installer by pasting the files copied earlier. 
  • Run the setup file from the local copy of the OS installer and finish the OS upgrade process. 

 

Issue 15

Issue Description

Upgrading the Virtual Desktop Agent from v2206 to v2209 on a Windows 10 22H2 machine shows a message saying “This program might not have installed correctly” by Program Compatibility Assistant.
[HDX-45244]

Problem Cause

Changes in Windows 10 v22H2 Operating System are causing this issue.

Solution
Citrix is working on a resolution.

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Issue/Introduction

Microsoft releases software updates for Windows 10 twice a year through the Semi-Annual Channel. Microsoft released its Semi-Annual Channel 'May 2020 update' (v2004) in May 2020, 'October 2020 update' (20H2) in October 2020, 'May 2021 update' (21H1) in May 2021, 'November 2021 update' (21H2) and '2022 Update'. This article is intended to capture known issues with Windows 10 v2004, 20H2, 21H1, 21H2, and 22H2 that have been identified so far through Citrix internal testing and customer reports.