Workspace App for Windows - Your apps are not available at this time - Issue when installing Citrix Receiver in not elevated/per-user install mode

Workspace App for Windows - Your apps are not available at this time - Issue when installing Citrix Receiver in not elevated/per-user install mode

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Article ID: CTX249920

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
Non-admin users must contact their company's Help Desk/IT support team and can refer to CTX297149 for more information.

 

The Organization is deploying Workspace App for Windows for the users. Some of these users have previously installed the non-administrator (not elevated/per-user install) version of Receiver. 
Some users are experiencing problems post to installing Workspace App for Windows, while connecting to the store URL.

The users receive an error message which says: 

"Your apps are not available at this time. Please try again in a few minutes or contact your help desk with this information: Cannot contact Store" 

The Administrators used Citrix Receiver Cleanup Utility while installing the full administrator version of Workspace App.

Can see the following in the AuthManager logs: 
Tue Feb 5 13:06:09 2019 Err : Failed to create the AuthManSvrLib::AuthManager CoClass ({0579B1B3-3F62-4E7B-9169-C7E112E2F151});
Tue Feb 5 13:06:09 2019 Err : AddAuthManager Caught unexpected COM HRESULT code 2147654730 while creating / setting up new auth manager.
Tue Feb 5 13:06:09 2019 Err : CitrixAuthManagerSDK::AMImplementationV1::CreateConnection failed with thread worker returning 2147654730 
Tue Feb 5 13:06:09 2019 Err : CitrixAuthManagerSDK::AMImplementationV1::CreateConnection: caught COM error 2147654730 

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Solution 1:
Deleting/resetting the local Windows profile.

Solution 2:

If an user installs Citrix Receiver/Workspace App (not elevated/per-user install) and then uninstall it using Receiver Clean-up Utility (running as an administrator/elevated), while the regular user is still logged in and has their profile loaded.
The below is a high-level list of Receiver related entries that may be left behind in the registry, verify them and clear the registries: 

  • HKCU\Software\Classes\* – File Associations and COM object registrations
  • HKCU\Software\Classes\AppID\* – AppID registrations
  • HKCU\Software\Classes\Applications\* – More app registrations
  • HKCU\Software\Classes\* – COM object registrations
  • HKCU\Software\Classes\CLSID\* – MANY COM class object GUIDs
  • HKCU\Software\Classes\WOW6432Node\CLSID\* – MANY COM class object GUIDs (32-bit)
  • HKCU\Software\Classes\Interface\* – MANY interface name to interface ID mappings
  • HKCU\Software\Classes\WOW6432Node\Interface\* – MANY interface name to interface ID mappings (32-bit)
  • HKCU\Software\Classes\MIME\Database\Content Type\* – x-ica MIME types
  • HKCU\Software\Classes\PROTOCOLS\Filter\* – Protocol filter handlers
  • HKCU\Software\Classes\Record\*
  • HKCU\Software\Classes\TypeLib\*
  • HKCU\SOFTWARE\MozillaPlugins\* – Firefox plugin registrations
  • HKCU\Software\Microsoft\Installer\Products – MSI installer product codes
For reference
You may have to clear the entries as shown in the below screenshot:



Caution
Incorrectly editing/deleting the registry may render your system inoperable - requiring the re-installation of Windows. Please take a backup of the registry key hive before editing/removing keys.

Problem Cause

Registry keys not getting properly removed while using Citrix Receiver Clean-up Utility