XenApp/XenDesktop 7.15 LTSR CU2 and CU3: Citrix Director DashBoard Does Not Report All User Connection Failures

XenApp/XenDesktop 7.15 LTSR CU2 and CU3: Citrix Director DashBoard Does Not Report All User Connection Failures

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Article ID: CTX249871

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Updated On:

Description

Citrix Director dashboard does not report all user connection failures (Over last hour). 

You use the below PowerShell script to get the user connection failure count using poweshell cmdlet "Get-BrokerConnectionLog". However, the count shown in Citrix Director Dashboard for user connection failures is less than the output of the below script.

PowerShell Script:

"Total FAILED Connection COUNT over past 60 min * * * *"
$when = [DateTime]::Now - [TimeSpan]::FromMinutes(60)
#$ConnFailures = Get-BrokerConnectionLog -AdminAddress $DDC -MaxRecordCount 99999 -Filter {BrokeringTime -gt $when -and ConnectionFailureReason -ne 'None'} -SortBy '+MachineName,-EndTime' | out-gridview
$ConnFailAllCount = Get-BrokerConnectionLog -AdminAddress $DDC -MaxRecordCount 99999 -Filter {BrokeringTime -gt $when -and ConnectionFailureReason -ne 'None' -and ConnectionFailureReason -ne $null} | Select Count ,Name, $CurrentDate
Write-Host $ConnFailAllCount.count -ForegroundColor DarkRed -BackgroundColor Yellow 

This issue was not seen with XenApp/XenDesktop 7.13.
 

Resolution

A private fix has been created for Monitor Service to address this issue under LD0726. The fix will most likely be integrated in 7.15 LTSR CU4.

Contact Citrix support to get the private fix for 7.15 LTSR CU2 and CU3.

Problem Cause

Known issue in the product.

Issue/Introduction

Citrix Director Does Not Report All User Connection Failures