[Citrix Receiver 4.9.5000 for Windows] - Display Issues when user re-docks their Notebook on the docking station and reconnecting to Citrix Session with Multiple Monitors
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Article ID: CTX249798
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Updated On:
Description
This article is intended for Citrix administrators and technical teams only.Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information
Scenario:
Users using notebooks and working with full screen sessions (without desktop viewer) to access their Citrix session, aka mobile thin client.
The users usually have a docking station and two identical monitors at their workplace.
When these users come back from a meeting and re-dock into their docking station the Citrix session gets reconnected, as desired.
Unfortunately the Citrix session doesn't recognize the second screen anymore. Instead, the window opens with scroll bars horizontally and vertically using the old screen resolution.
Display looks like below while re-docking the Notebook and reconnecting the session using Citrix Receiver 4.9.5000:

Regarding the scroll bars, it seems like the session still knows the resolution of the two monitors, but won't scale to full screen anymore.
Because it's a full screen view of the screen the user then has no other choice than to restart the session to get this fixed.
This issue is seen only when working with dual monitor and full screen session without desktop viewer.
Steps to reproduce the issue:
- Start a new Citrix session on a notebook with docking station an two monitors.
- The notebook remains closed.
- Remove the notebook from the docking station without opening the notebook.
- Reconnect the notebook to the docking station without opening the notebook.
- You can find a print screen in the attachment showing the issue with Receiver 4.9.5000 after reconnecting the docking station.
Resolution
Test with below registries on the client side (create them if not present on the client machine):
Set ProcessWM_SETTINGCHANGE to 1
On Windows 32-bit systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client
Name: ProcessWM_SETTINGCHANGE
Type: DWORD
Value: 1 (default value is zero) (this fix is only for users who disable CDViewer Bar and run Desktop in full-screen mode)
On Windows 64-bit systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client
Name: ProcessWM_SETTINGCHANGE
Type: DWORD
Value: 1 (default value is zero) (this fix is only for users who disable CDViewer Bar and run Desktop in full-screen mode)
Set MonitorLayoutUpdateDelay to 4
On Windows 32-bit systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\ICA Client
Name: MonitorLayoutUpdateDelay
Type: DWORD
Value: 0 to 4 (default value is zero)
On Windows 64-bit systems:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\ICA Client
Name: MonitorLayoutUpdateDelay
Type: DWORD
Value: 0 to 4 (default value is zero)
Problem Cause
Display Issues while reconnecting to the session with multiple monitors from a dock station.
Issue/Introduction
This article provides resolution to the display issue which occurs while user re-dock their notebook to the docking station attached to dual monitors.
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