iOS devices failing to enrol via NetScaler after upgrade to 11.1 60.13

iOS devices failing to enrol via NetScaler after upgrade to 11.1 60.13

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Article ID: CTX240137

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Updated On:

Description

After upgrading NetScaler to 11.1 60.13, iOS devices are no longer able to enroll
However, Android devices are not affected.

iPhone X can enroll but can't access the Store
iPhone 7 can't enroll at all

Checking the logs, we would be able to see the below, when iOS attempts to enroll:
"AAA Client Handler: Found extended error code 589827, ReqType 16386 request /AGServices/discover, cookie hdr "

Resolution

This is a known issue with NetScaler, where it will drop the enrollment request when trying to pass it to the LB vServer on port 8443

There is no workaround in place, and is fixed in 11.1 61.7 and all versions of 12.0 and 12.1

Problem Cause

Known issue with 11.1 60.x build, relating to iOS Device Enrollment