Receiver installation fails after using ReceiverCleanupUtility

Receiver installation fails after using ReceiverCleanupUtility

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Article ID: CTX240109

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

Receiver upgrade fails during the automatic uninstallation, this happens with multiple versions of Receiver.
We can work around the problem at uninstallation with the ReceiverCleanupUtility, followed by a reboot. However installation of Receiver keeps failing after this.
 
Logs show the following:
 
=== Verbose logging started: 17/04/2018  16:48:13  Build type: SHIP UNICODE 5.00.7601.00  Calling process: C:\Extract4_11\Extract\TrolleyExpress.exe ===
MSI (c) (F4:14) [16:48:13:246]: Resetting cached policy values
MSI (c) (F4:14) [16:48:13:246]: Machine policy value 'Debug' is 0
MSI (c) (F4:14) [16:48:13:246]: ******* RunEngine:
           ******* Product: C:\Extract4_11\Extract\RIInstaller.msi
           ******* Action:
           ******* CommandLine: **********
MSI (c) (F4:14) [16:48:13:247]: Client-side and UI is none or basic: Running entire install on the server.
MSI (c) (F4:14) [16:48:13:249]: Grabbed execution mutex.
MSI (c) (F4:14) [16:48:13:250]: Cloaking enabled.
MSI (c) (F4:14) [16:48:13:250]: Attempting to enable all disabled privileges before calling Install on Server
MSI (c) (F4:14) [16:48:13:251]: Incrementing counter to disable shutdown. Counter after increment: 0
MSI (c) (F4:14) [16:48:13:251]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied.  Counter after decrement: -1
MSI (c) (F4:14) [16:48:13:252]: MainEngineThread is returning 1601
=== Verbose logging stopped: 17/04/2018  16:48:13 ===
 
 
In the example above, installation RIInstaller.msi fails when executed by TrolleyExpress.exe. But it succeeds when installed manually as a standalone components. The same is true for all other MSIs included in Receiver.
 
16:48:13: Error - CtxInstallHelpers::CInstalledClientPkg::GetProductInfo(192) - Error 1605 querying product information for product code {97509D48-ABF9-46DA-8511-FE505CB6B714}.
16:48:13: Error - CtxInstallHelpers::CInstalledClientPkg::GetProductInfo(192) - Error 1605 querying product information for product code {97509D48-ABF9-46DA-8511-FE505CB6B714}.
16:48:13: Error - CtxInstallHelpers::CInstalledClientPkg::FindInstalledClientsHelper(286) - Cannot get the version string for existing package, product code {97509D48-ABF9-46DA-8511-FE505CB6B714}.
16:48:13: Information - CInstallationManager::InstallComponents(1283) - Modified RI INSTALLDIR is: C:\Program Files (x86)\Citrix\ICA Client\Receiver
16:48:13: Information - CInstallationManager::InstallComponent(1937) - Running InstallComponent method for: ReceiverInside.
16:48:13: Information - CInstallationManager::InstallComponent(1984) - Installing Component: ID = ReceiverInside
16:48:13: Information - CInstallationManager::InstallComponent(2153) - Component Install Commandline: REBOOT=ReallySuppress MSIDISABLERMRESTART=0 MSIRESTARTMANAGERCONTROL=0 ARPSYSTEMCOMPONENT=1 NEED_RECEIVER=n TROLLEYINSTALL=1 INSTALLDIR="C:\Program Files (x86)\Citrix\ICA Client\Receiver" ALLUSERS=1
16:48:13: Information - CInstallationManager::InstallComponent(2179) - MSI Install from path : C:\Extract4_11\Extract\RIInstaller.msi
16:48:13: Information - CInstallationManager::InstallComponent(2251) - Component Install Status: ID = ReceiverInside, InstallMode = Install, InstallResult = 1601, InstallSuccess = False, InstallRebootRequired = False, InstallSuppressed = False
16:48:13: Information - CInstallationManager::InstallComponent(2276) - InstallComponent complete for ReceiverInside.
16:48:13: Information - CInstallationManager::InstallComponents(1322) - Component result is false: 0
16:48:13: Error - CComponentManager::GetInstallStatus(601) - Installation NOT successful for 'Receiver Inside', error: 1601.
 

Environment

This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.

Resolution

Use the following Command to register msi.dll:

regsvr32 %windir%\syswow64\msi.dll


Problem Cause

The issue was with the Windows Installer. The msiexec.exe file in syswow64 folder was throwing error during installing any msi's.  Registering c:\windows\syswow64\msi.dll fixes the issue.