One Way Voice Traffic Through Citrix Gateway VPN with Softphone

One Way Voice Traffic Through Citrix Gateway VPN with Softphone

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Article ID: CTX239685

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Updated On:

Description

 User cannot be heard with other soft-phones when connected to the full VPN through Citrix Gateway. User is able to hear callers, but callers cannot hear them.
If a non soft phone that is connected to the VPN  is called the call works as expected
 


Deployment: 
Citrix Gateway Full VPN with split tunnel on  

Resolution

Complete the following steps to resolve this issue:
Split Tunnel requires that the networks the VPN Client will send traffic to are specified on the Citrix Gateway. These are referred to as Intranet Applications on the Citrix Gateway 
Refer to CTX205285 for details on split tunnel. 

  1. Create a new intranet IP with the Network range of the destination devices or correct portion and netmask of an existing one, and specify the protocol as UDP or ANY.

Problem Cause

Missing destination subnet from intranet application configuration on the Citrix Gateway and VPN Plugin not sending the traffic through the VPN Tunnel.

Issue/Introduction

User cannot be heard with other soft-phones connected to the full VPN through Citrix Gateway. User is able to hear callers, but callers cannot hear them. If a non soft phone that is connected to the VPN  is called the call works as expected. Ensure that in a split tunnel scenario all subnets allowed through the VPN are specified as Intranet Applications.

Additional Information

If you take a trace on the Citrix ADC you will be able to see that there is only traffic sourcing from the destination client and no traffic being send from the source when the affected user is speaking. This is caused by the missing Intranet Application which instructs the VPN client which traffic to send through the VPN tunnel. 
To additionally test this you can set the split tunnel to off. Have the affected user log off and log back on and test.