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Article ID: CTX239584
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Updated On:
Description
Start menu is blank after VDA upgrade from 7.6.3000 to 7.15 CU3 with Citrix UPM as profile management solution.
Resolution
To resolve the issue perform the following steps:
- Configure the following registry key to be called at logon from Logon Scrip GPO:
- Open the registry and create the following registry key in one of the VDA:
- HKCU\Software\Microsoft\Windows\CurrentVersion\ImmersiveShell\StateStore\
- DWORD: ResetCache
- Value: 1
- Export the Key and edit the .reg file exported.
- Leave only the "ResetCache" key and remove all the other keys.
- Create a batch file with the following command:
- regedit /s "C:\My Reg Files\MyRegFile.reg" (MyRegFile.reg is the name given to the ResetCache key exported)
- Create a GPO (domain or local) to run the batch file as a Logon Script.
Note: This registry key is set to 1 only during users logon process. After the users login the OS sets the key back to 0. In some scenarios the use of this registry key may cause a black screen shown for several seconds during the session launch process.
This issue is suppose to be fixed on VDA 7.15 CU3 and 7.18, but only for fresh installation scenarios. The workaround provided here is for scenarios where the VDA was upgraded from previous version. If the VDA 7.15 CU3 was upgraded from a previous version, you can remove the VDA using the VDA CleanUp utility, reboot the machine and proceed to install the VDA 7.15 CU3 fresh.
Workaround
For VDA upgrade scenarios is to
configure the Folder to Mirror policy and Add “AppData\Local\Microsoft\Windows\Caches" manually either in the HDX Group Policy Editor or in the Active Directory Policy Editor, from article CTX238419-
UPM 7.15.2000: With Profile Management Enabled, Blank Icons Might Appear In The Start Menu In The Published Desktops
Problem Cause
This is a Known issue.