Citrix Workspace app for Mac unable to see USB device

Citrix Workspace app for Mac unable to see USB device

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Article ID: CTX239479

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Updated On:

Description

A USB Joystick has been tested successfully from a windows client. USB device pass through is configured on a Citrix policy via Studio, but USB device options on mac receiver client show "Policy Restricted" in the "Virtual Channel" column. Customer tried updating the local policy by editing the /library/Application Support/Citrix Receiver/USB.conf file and setting the Citrix USB device redirection rule policy to "Use default" which did not help. reference: https://support.citrix.com/article/CTX137939, https://docs.citrix.com/en-us/receiver/mac/current-release/configure.html.

Resolution

Move the enable line to the top of the config file and the device works as expected.

/library/Application Support/Citrix Receiver/USB.conf 

# Syntax is an ordered list of case insensitive rules where # is line comment
#  and each rule is (ALLOW | DENY) : ( match ( match )* )?
#  and each match is (class|subclass|prot|vid|pid|rel) = hex-number
# Maximum hex value for class/subclass/prot is FF, and for vid/pid/rel is FFFF
ALLOW: vid=07C0 pid=1131 # axis controller CR939 # moved device line to top of file
DENY: vid=17e9 # All DisplayLink USB displays
DENY: class=02 # Communications and CDC-Control
DENY: class=09 # Hub devices
DENY: class=0a # CDC-Data
DENY: class=0b # Smartcard
DENY: class=e0 # Wireless controller
DENY: class=ef subclass=04 # Miscellaneous network devices
ALLOW: # Otherwise allow everything else

Problem Cause

Device was being blocked by one of the other devices in the conf file.

Issue/Introduction

Customer modified USB configuration file to add device but it still doesn't work.