Workspace App for Windows - Error "Cannot start app" intermittently

Workspace App for Windows - Error "Cannot start app" intermittently

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Article ID: CTX238963

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

Intermittently application launch fails with errors "Cannot start" or "Cannot start app"
In Windows Task Manager there will be multiple instance of wfcrun32.exe for the same user.
Ending all the instances except one fixes the issue and app launch works.

User-added image

Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

In Receiver's error file you will find following message:

Launch error code: 3
Error launching the ICA file
Unable to launch using CCM (url)
at Dazzle.LaunchUtils.ICALaunchUtils.LaunchViaFile(String quotedIcaFilePath, String cmdline, String url)


Create the following exclusions for Imprivata hooking files in the client/end point registry: 
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SSOProvider\ISXAgent\HookInit] 
"Concentr.exe"="" 
"SelfService.exe"="" 
"AuthManSvr.exe"="" 
"Receiver.exe "="" 
"SelfServicePlugin.exe"="" 
"wfcrun32.exe"="" 

Problem Cause

Imprivata SSOn hooking with Receiver's EXEs

Issue/Introduction

Workspace App for Windows giving error "Cannot start app" and in task manager there will be multiple instance of wfcrun32.exe running under the same user.