Microsoft releases software updates for Windows 10 twice a year through the Semi-Annual Channel. Microsoft released its Semi-Annual Channel called 'May 2019 Update' (v1903) in May 2019 and released its next Semi-Annual Channel called 'November 2019 Update' (v1909) in November 2019.
This article is intended to capture known issues with Windows 10 v1903 & v1909 that have been identified so far through Citrix internal testing and customer reports.
Note:
Issue Description
Print command from inside an ICA session of Windows 10 v1903/v1909 end point fails to print with client mapped printers using the Citrix XPS Universal Printer driver.
[HDX-13664]
Problem Cause
XPS Viewer is not available on Windows 10 v1803 and later versions by default. It is available as a Feature on Demand.
Solution
To install XPS Viewer, follow the below steps:
Note:
Issue Description
Citrix User Profile Manager (UPM) stops working after Windows 10 is upgraded to Windows 10 v1903.
[TPV-1307]
Problem Cause
Some of the registry keys related to Citrix UPM are getting removed during upgrade process.
Solution
This issue is fixed with the Microsoft's March 2019 Updates for Windows 10. Install the respective March 2019 update OR its replacement on your existing Windows 10 version before upgrading to Windows 10 v1903.
Users are advised to install KB4505903 OR its replacement and then try to uninstall Desktop Lock.
Issue Description
Printers part of Universal Print Server are no longer mapped after Windows 10 is upgraded to Windows 10 v1903. This issue is not seen with fresh install of Windows 10 v1903.
[LCM-5677]
Solution
There is no solution. Support for custom print drivers have been deprecated by Microsoft.
Issue Description
Unable to print using mapped printers if Universal Print Driver is used with Windows 10 v1903 VDA.
[LCM-5691]
Solution
Citrix is working with Microsoft to resolve this issue. This has been fixed with next version of Windows 10 (20H1) build 18999 and above.
Issue 6
Issue Description
"Direct3D11 error: out of memory" error message may be seen within VDA with Applications like Unigine Heaven 3.0 in DirectX 11 mode on Windows 10 v1903 x64 build 18342
[LCM-5714]
Problem Cause
DirectX 11 enabled apps inside VDA with a GPU assigned fails to work with an out of memory error.
Solution
There is no solution at this time. Citrix is working with Microsoft to resolve this issue.
Issue Description
On Windows 10 v1903 end point with Receiver/Workspace App, when a network interruption is caused using Firewall, Session Reliability feature fails to work.
[RFWIN-15263]
Problem Cause
Changes in Windows 10 v1903 Operating System is making the Session Reliability to fall back to Auto Client Reconnect as soon as the the network is disrupted.
Solution
This issue has been fixed in KB4566116. Install this KB OR its replacement on endpoints to resolve this issue.
Issue Description
On Windows 10 v1903 end point with Receiver/Workspace App, when a network interruption is caused by disabling the Network Interface from Control Panel, Session Reliability feature fails to work.
[RFWIN-15116]
Problem Cause
Changes in Windows 10 v1903 Operating System is making the Session Reliability to fall back to Auto Client Reconnect when the network is disrupted.
Solution
This issue has been fixed in Citrix Workspace App.
Issue Description
When Windows 10 machine with Citrix Workspace Environment Management (WEM) Agent 1803 or newer is upgraded to v1903/v1909, WEM fails to work. This issue is not seen with WEM versions up to 4.7
[TPV-1184]
Problem Cause
The ‘Norskale’ key under [HKLM -> System -> CurrentControlSet -> Control] is removed during the upgrade to v1903.
Solution
This issue is fixed with Windows 10 v2004 and newer versions.