Microsoft Office Live Preview option unavailable after session reconnect

Microsoft Office Live Preview option unavailable after session reconnect

book

Article ID: CTX238303

calendar_today

Updated On:

Description

Under certain conditions, when you launch MS Office applications (such as Word, Excel or PowerPoint) from within a published desktop, "Live Preview" is disabled and greyed out as shown in the screenshot below --

User-added image
 

Resolution

To resolve this issue, follow the steps below on the VDA hosting MS Office application --

1.) Launch sysdm.cpl
2.) Click on "Advanced" tab
3.) Click on "Settings" under "Performance"
4.) Check the radio button "Adjust for best appearance"
5.) Click "Apply" and "OK"
6.) Launch Registry Editor
7.) Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix
8.) Create a new REG_DWORD "EnableVisualEffect" and give it a Value data of 1
 

Problem Cause

This behavior is by design. Citrix overrides UserPreferenceMask on logon/reconnect. UserPreferenceMask represents a mask of bits that correspond to various user interface (UI) settings. To learn more about it, see the following Microsoft article -- https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-2000-server/cc957204(v=technet.10)
 

Additional Information

"Live Preview" in MS Office applications (such as Word, Excel and PowerPoint) shows a preview of how a feature affects the document as you hover over different choices and is directly linked to the Performance settings of the machine.