Citrix Workspace App Launcher is unable to launch applications automatically with Safari 12
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Article ID: CTX238285
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Updated On:
Description
This article is intended for Citrix administrators and technical teams only.
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.
Citrix Workspace App Launcher is not able to launch applications automatically with Safari browser version 12. Citrix Workspace App launcher is not able to trigger the application launch on the Safari 12 browser. This issue is happening after the upgrade of Safari 12.
Environment
This software application is provided to you as is with no representations, warranties or conditions of any kind. You may use and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that: (a) the software application may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the software application fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the software application. In no event should the software application be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SOFTWARE APPLICATION, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the software application.
Resolution
Perform the following steps to resolve the issue:
1. Clean Uninstall the Citrix Workspace App using the Uninstall option inside the downloaded .dmg file.
2. Reboot the client machine.
3. Install the Citrix Workspace App for Mac
Problem Cause
Upgrade from previous version of Receiver for Mac to Citrix Workspace App for Mac seems incompatible with Safari 12, when NPAPI support is removed from Safari 12
Issue/Introduction
Citrix Workspace App Launcher is not able to launch applications automatically with Safari browser version 12 after NPAPI support is being removed from Safari 12
Additional Information
https://www.citrix.com/blogs/2018/08/03/npapi-support-is-being-removed-from-safari-12/
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