Director: HTTP Error 503. The service is unavailable

Director: HTTP Error 503. The service is unavailable

book

Article ID: CTX237964

calendar_today

Updated On:

Description

After upgrading the Citrix Director sometimes the console will not open, getting an error "HTTP Error 503. The service is unavailable on the browser."

Resolution

IIS comes with a feature called Rapid-Fail protection. By default an App Pool is configured to become disable for the following reasons:
1> if a worker in the pool crashes 5 times within a 5 minute span.
     OR
2>Permissions issue for DefaultAppPool identity.
     OR
3>Junk files created under C:\inetpub\temp\AppPools folder

Solution 1
The thresholds of this settings can be modified by right clicking on the App Pool going into Advanced settings and Modifying the 'Rapid-Faile Protection' properties.
User-added image

Solution 2
Verify the Identity by right clicking on the AppPool going to Advanced Settings and under process model Identity. Try modifying the Identity to Network Service and check if the Default App Pool is starting and able to browse the site.
User-added image
If the issue still persists, include DefaultAppPool and Director Application Pool under administrators group and check the director site access. To add DefaultAppPool and Director into administrators group follow the below instructions.
Open Computer Management -> Expand Local Users and Groups -> Double Click -> Administrators Group -> Click Add -> Change the location to local computer - > Type IIS AppPool\DefaultAppPool - > Click Check Names to resolve the name. Perform the same for Director AppPool.
User-added image

Solution 3
Stop IIS and WAS services
Browse to C:\inetpub\temp\appPools folder and delete all files (Take appropriate Backup before deleting these files) 
Start WAS and IIS services to recreate the folder and files.
Browse the site.
 

Problem Cause

Broken Permissions on IIS application pools while performing the upgrade of the application

Issue/Introduction

After upgrading the Citrix Director sometimes the console will not open, getting an error "HTTP Error 503. The service is unavailable on the browser."

Additional Information

Reference links for reading:
https://docs.microsoft.com/en-us/iis/manage/configuring-security/application-pool-identities
https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc735229(v=ws.10)