Win7 MCS Machines BSOD With Error: 0x0000007E
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Article ID: CTX237395
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Updated On:
Description
After booting a VM from a Machine Catalog using MCS I/O, users are able to logon and their profiles load successfully, but within a few minutes, their session is disconnected.
Citrix Studio show users are still connected, but Citrix Admin is unable to access machine in Director.
When accessing machine via the hypervisor, it shows a blue screen with error 0x0000007E.

Resolution
When creating Machine Catalogs with the MCS I/O feature:
1. Make sure the "Memory allocated to cache (MB)" and the "Disk cache size (GB)" boxes are populated when running the Machine Catalog Setup wizard.
Note: If you do not want to use the feature, clear both boxes and temporary data will not be cached (see the information on the red box below).

2. After the virtual machine has been created, log on the VM and check that an extra uninitialized disk exists on Disk management. Do not attempt to format it or initialize it.

3. If there is no extra cache drive on the VDAs, the catalog needs to be recreated.
Problem Cause
The extra drive for the write back cache was not created, and when the temporary memory has reached its threshold, the cached data cannot be written to a hard disk, thus the machine bluescreens.
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