Error: "Gateway is not Reachable” or Connection Goes Down After the VPN Tunnel is Established

Error: "Gateway is not Reachable” or Connection Goes Down After the VPN Tunnel is Established

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Article ID: CTX236853

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Description

After the VPN tunnel is established, the machine’s connection goes down and VPN plugin screen shows “Gateway is not reachable”. This connection going down can happen for a Wi-Fi adapter, a 3G/4G adapter and even an ethernet adapter.

Resolution

To resolve this issue upgrade to 12.0-61.x or 12.1-51.x or later. 

To workaround this issue disable following two group policies:
Group Policy 1
Microsoft article for reference: https://support.microsoft.com/en-us/help/2919900/windows-connection-manager-disconnects-wlan-if-a-vpn-connection-is-est

Group Policy 2
Microsoft article for reference: https://blogs.technet.microsoft.com/secguide/2017/08/30/security-baseline-for-windows-10-creators-update-v1703-final/

Problem Cause

This issue will only happen when Intranet IP [IIP] feature is enabled. This happens because of following issues.

  1. Citrix Virtual Adapter is registered as an Ethernet adapter. Starting with Windows 8, the WCMSVC (Windows Connection Manager) disconnects low speed connections because an Ethernet Adapter is seen as more reliable and provides better performance compared to other adapters. That’s the reason, Wi-Fi, 3G/4G adapters get disconnected. But those connections are needed for actual communication with VPN gateway, VPN plugin shows “Gateway is not reachable”. 

  2. After establishing VPN tunnel, Citrix Virtual Adapter gets registered as a domain network. If a client machine is connected to a domain network, depending upon group policy configuration the Windows Connection Manager blocks connections over non-domain networks. Because of this blocking, VPN plugin can’t reach VPN gateway and it shows “Gateway is not reachable”.