book
Article ID: CTX236485
calendar_today
Updated On:
Description
Users can't start a specific application through Citrix.
Resolution
-
In the server Group Policy Management Console, navigate to Local Computer Policy > User Configuration > Windows Settings.
-
Click Scripts (Logon/Logoff), and then double-click Logon.
-
Click Add.
-
In the Script name box, type runonce.exe.
-
In the Script parameters box, type /AlternateShellStartup.
-
Click OK two times.
Problem Cause
By design, the TS RemoteApp session implements limited functionality. This issue occurs because you try to start an application that relies on the Explorer.exe file.
If
wfshell is not loaded, the default.profile is not created correctly. This behavior occurs because when the explorer shell is not loaded with the Run registry entry, the RunOnce registry entry and the startup applications are not loaded. If you start a published application which depends on wfshell, it might fail to load because of dependencies executed in the
runonce command.