Can't start a specific application which relies on Explorer.exe

Can't start a specific application which relies on Explorer.exe

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Article ID: CTX236485

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Updated On:

Description

Users can't start a specific application through Citrix.

Resolution

  1. In the server Group Policy Management Console, navigate to Local Computer Policy > User Configuration > Windows Settings.

  2. Click Scripts (Logon/Logoff), and then double-click Logon.

  3. Click Add.

  4. In the Script name box, type runonce.exe.

  5. In the Script parameters box, type /AlternateShellStartup.

  6. Click OK two times.


Problem Cause

By design, the TS RemoteApp session implements limited functionality. This issue occurs because you try to start an application that relies on the Explorer.exe file.

If wfshell is not loaded, the default.profile is not created correctly. This behavior occurs because when the explorer shell is not loaded with the Run registry entry, the RunOnce registry entry and the startup applications are not loaded. If you start a published application which depends on wfshell, it might fail to load because of dependencies executed in the runonce command.

Additional Information

An application does not start in a Windows Server 2008 Terminal Services RemoteApp session
https://support.microsoft.com/en-ca/help/951048/an-application-does-not-start-in-a-windows-server-2008-terminal-servic