ICA Desktop And Application Sessions Disconnect Immediately After Successful Launch

ICA Desktop And Application Sessions Disconnect Immediately After Successful Launch

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Article ID: CTX236306

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Description

  • ICA Desktop sessions or Applications disappear immediately after successful launch.
  • The sessions state changes to "Disconnected".
  • In Task Manager you see two instances of wfshell.exe for each disconnected ICA session.
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Environment

Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.

Resolution

Remove the extra entry for cmstart.exe from the registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\AppSetup on the VDA 
 

Problem Cause

There were two cmstart.exe entries present under registry HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\AppSetup.

cmstart2


CMSTART.EXE is responsible for starting WFSHELL.EXE which loads the virtual channels and CLTMGR.EXE which is the client manager. Since there were two entries for cmstart.exe, it started two wfshell.exe instances for each  session with each sending a EUEM (End User ExperienceMonitoring channel, related to HDX) bind request to the client with the second bind getting rejected resulting in a closed connection.
 

Issue/Introduction

ICA Desktop And Application Sessions Disconnect Immediately After Successful Launch

Additional Information

Purpose of CMSTART command
https://support.citrix.com/article/CTX983798

Application Launch Error: "The Citrix server is unable to process your request to start this published application at this time."
https://support.citrix.com/article/CTX132243