Unable to launch apps with error "Cannot Start App"

Unable to launch apps with error "Cannot Start App"

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Article ID: CTX236101

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Updated On:

Description

Unable to launch apps from VDA with error "Cannot Start App"
Storefront shows error - Failed to launch the resource using the Citrix XML service at address......The XML service returrned error:"no -available-workstation"
Error 1101 on DDC - Citrix Broker service failed to broker a connection for user

Resolution

On the affected VDA, locate the registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\TSServerDrainMode
Change the value from 2 to 0.

Reboot the server.
From the DDC, Run Get-BrokerMachine and verify that the affected machine now shows WindowsConnectionSetting set to LogonEnabled.
You should be able to launch apps and desktops.
 

Problem Cause

Run Get-BrokerMachine -Machinename [AffectedVDA]
WindowsConnectionSetting property showed Draining instead of LogonEnabled.

Additional Information

Found similar article with another registry key that could cause similar launch issues CTX139160.