Error: "Cannot Complete Your Request" After Publishing New App or Customizing App’s Icon on StoreFront

Error: "Cannot Complete Your Request" After Publishing New App or Customizing App’s Icon on StoreFront

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Article ID: CTX235970

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Updated On:

Description

The following error is displayed after publishing a new application or customizing an application’s icon on StoreFront:
Cannot Complete Your Request

Resolution

If you experience the error after publishing a new application or customizing an application’s icon, check the event viewer on the StoreFront server and look for the following errors when the issue occurs:
Event 1 = There was an error during a resources List request. System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
The remote server returned an error: (500) Internal Server Error.
Event 7 = Unhandled exception thrown for route "DazzleResources/List" System.ArgumentException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 Offset and length were out of bounds for the array or count is greater than the number of elements from index to the end of the source collection.

If yes, troubleshoot the issue by following steps:

  1. Go to Studio > Delivery Groups > Applications > Properties of the application recently added > Delivery > Application Icon 
  2. Change and choose from any of the Citrix default icons.
  3. Test if the issue is not reproduced. If not, use default icons or try with other customized icons.

Problem Cause

The following error is displayed due to publishing a new application or customizing an application’s icon,

Issue/Introduction

The following error is displayed after publishing a new application or customizing an application’s icon on StoreFront: Cannot Complete Your Request

Additional Information

CTX207162 - Error: "Cannot Complete Your Request" When Connecting to StoreFront