Error: "Cannot Complete Your Request" Due to Citrix Delivery Services Authentication App Pool Misconfiguration on StoreFront

Error: "Cannot Complete Your Request" Due to Citrix Delivery Services Authentication App Pool Misconfiguration on StoreFront

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Article ID: CTX235921

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Updated On:

Description

The following error is displayed due to Citrix delivery services authentication app pool misconfiguration on StoreFront:
Cannot Complete Your Request

Resolution

On the IIS console go to Application Pools and confirm that Citrix Delivery Services Authentication app pool is configured to use .NET CLR Version 4.0. If the app pool is not using .NET 4.0, refer to Microsoft article - Specify a .NET Framework Version for an Application Pool (IIS 7) and restart the Citrix Credential Wallet Service using the following procedure:

  1. Open services.msc console on the StoreFront server.
  2. Search for the service Citrix Credential Wallet Service > right-click > Restart.

Problem Cause

This issue is caused due to Citrix delivery services authentication misconfiguration on StoreFront.

Issue/Introduction

The following error is displayed due to Citrix delivery services authentication app pool misconfiguration on StoreFront: Cannot Complete Your Request

Additional Information