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Article ID: CTX235909
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Updated On:
Description
The following error is displayed due to authentication misconfiguration on StoreFront:
Cannot Complete Your Request
Resolution
Complete the following steps to troubleshoot this issue:
- Open the Citrix StoreFront management console > Stores > Manage Authentication Methods and make sure user name and password is enabled. To enable it, check the User Name and Password box and click OK. NOTE : If you are passing authentication from the Gateway, make sure HTTP Basic is not checked.
- On the Citrix StoreFront management console > Stores > Manage Receiver for Web Sites > Click Configure. Under "Authentication Methods" make sure that User Name and Password is enabled. To enable it, check the User Name and Password box and click OK.
- In Active Directory confirm the User Logon Name matches the User Logon Name (pre-Windows 2000). For more information refer to article - User Name Formats.
- Go to StoreFront Server > Event Viewer, verify if there is error
- Event ID 8 "An unexpected error occurred storing the credentials" or
- Event ID 3 "An error occurred during authentication"
If yes, run the following PowerShell command and then restart the Citrix Credential Wallet Service:
cd 'C:\Program Files\Citrix\Receiver StoreFront\Scripts'
$certlist = @(Get-DSCertificate)[0] | where { $_.Subject -Match "Credential Wallet Replication Identity" }
foreach ( $cert in $certlist ) { Add-DSCertificateKeyReadAccess $cert "NT Service\CitrixCredentialWallet" }
Problem Cause
This issue is caused due to authentication misconfiguration on StoreFront.
Issue/Introduction
The following error is displayed due to authentication misconfiguration on StoreFront: Cannot Complete Your Request