Error: "Cannot Complete Your Request" Due to DNS Misconfiguration on StoreFront

Error: "Cannot Complete Your Request" Due to DNS Misconfiguration on StoreFront

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Article ID: CTX235907

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Updated On:

Description

The following error is displayed due to DNS misconfiguration on StoreFront:
Cannot Complete Your Request

Resolution

Complete the following steps to troubleshoot this issue:

  1. On the StoreFront server, go to the Citrix StoreFront management console > Server Group > Base URL, confirm that the StoreFront Base URL includes a full FQDN, not a hostname or an IP address.
Examples:
Base URL configured using Full FQDN: https://storefront.example.com
Base URL configured using hostname: https://storefront
Base URL configured using IP address: https://192.168.10.5
To change the Base URL, use the Change Base URL task. For more information, refer to Citrix Documentation - Change the base URL for a deployment
  1. For a single server deployment, on the StoreFront server, open the Command Prompt, ping the StoreFront Base URL, verify it resolves to the StoreFront server local IP address. If not, go to DNS Server and verify your DNS entry of the StoreFront Server is correctly configured.

Problem Cause

This issue is caused due to DNS misconfiguration on StoreFront.

Issue/Introduction

The following error is displayed due to DNS misconfiguration on StoreFront: Cannot Complete Your Request

Additional Information