Error: "Cannot Complete Your Request" Due to Call Back URL Misconfiguration on StoreFront

Error: "Cannot Complete Your Request" Due to Call Back URL Misconfiguration on StoreFront

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Article ID: CTX235881

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Updated On:

Description

The following error is displayed due to call back URL misconfiguration on StoreFront:
Cannot Complete Your Request

Resolution

Call back URL is the internally accessible URL of the appliance. This is used to verify that requests received from Citrix Gateway originate from that appliance.
Note: Callback URL is only needed if SmartAccess CVAD policies or password-less authentication methods (Smart Cards, SAML, and so on) are used. Or you should leave it as blank.

Ensure that call back URL is configured accurately as defined in the preceding points:
  1. The callback URLĀ must resolve to any Citrix Gateway VIP on the same appliance that authenticated the user.
  2. The callback URL must have a trusted and valid (not expired) certificate.
  3. The callback URL must be same as the FQDN to which the certificate is issued.
  4. The callback URL must not have client certificates set to Mandatory.

Problem Cause

This issue is caused due to call back URL misconfiguration on StoreFront.

Issue/Introduction

The following error is displayed due to call back URL misconfiguration on StoreFront: Cannot Complete Your Request

Additional Information

CTX207162 - Error: "Cannot Complete Your Request" When Connecting to StoreFront