7.15 LTSR CU2 Session Launches as a Black Screen with Profile Management Enabled
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Article ID: CTX235100
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Updated On:
Description
7.15 LTSR CU2 sessions might launch as a black screen. The issue occurs with sessions running on XenApp and XenDesktop 7.15 LTSR CU2 and 7.17 VDAs when Profile Management is enabled.
Environments:
VDA:
7.15 LTSR CU2, and 7.17 with Profile Management enabled
VDA OS:
Windows Server 2016
Windows 10
Environment
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Resolution
Workaround
A. Recover the VDA machine from the black screen:
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Log on as a local administrator. Even while the screen is black, you can start the Windows “Task Manager” as follows:
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Run regedit.exe from File > Create new task.

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Navigate to “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion” and create “AppReadiness” and “Appx\AppxAllUserStore” keys if they are missing.

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Run services.msc from File > Create new task.

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Find the Citrix Profile Management service, and change its startup type from Automatic to Manual.

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Restart the VDA. The regular desktop should appear as expected.
B. Run the attached PowerShell script to uninstall the earlier version of Profile Management.
C. Install the Profile Management package
- For XenApp and XenDesktop 7.15 LTSR CU2 environments, install the LTSR7.15 CU1 version of Profile Management. You can download it from https://www.citrix.com/downloads/xenapp-and-xendesktop/product-software/xenapp-and-xendesktop-715-ltsr-cu1-all-editions.html.
- For XenApp and XenDesktop 7.17 environments, install the 7.16 version of Profile Management. You can download it from https://www.citrix.com/downloads/xenapp-and-xendesktop/product-software/xenapp-and-xendesktop-716.html
D. Open “services.msc”, find the Citrix Profile Management service then change its startup type from Manual to Automatic.
E. Restart the VDA.
Note: When using the 7.15 LTSR CU1 or 7.16 versions of Profile Management, users might see blank tiles on the Start menu. See CTX234144 - Start Menu Shows Blank Icons on VDA 7.15 LTSR CU1/CU2/7.16/7.17 with UPM Enabled for a workaround.
Problem Fix
Update!: The issue has already been fixed in LTSR7.15. Refer to CTX235399 to download the hotfix. Apply the same procedure in this document, with the package from CTX235399 in step C. The issue has been fixed in XenDesktop 7.18 as well.
Problem Cause
Under certain circumstances, Profile Management deletes the two above-mentioned registry keys after session logoff. As a result, the session can appear as a black screen after the VDA restarts.
Issue/Introduction
7.15 LTSR CU2 session launches as a black screen with Profile Management enabled
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