Published application "Not Responding" and Freezing on Server OS VDAs
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Article ID: CTX234888
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Updated On:
Description
A particular application freezes during ICA seamless session and shows "Not Responding" then "Running" then back and forth between "Not Responding" / "Running"
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
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Apply Alternate shell startup login script "Runonce AlternateShellStartup) on the Master VDA image. https://support.citrix.com/article/CTX127874
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The end user will be getting a new endpoint device with more local resources.
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Keep running "Provider.exe" (the executable of the published application) in Windows 7 compatibility mode as recommended by the App vendor (This app worked fine in 6.5 environments).
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Make sure the following Microsoft KB's are installed in the VDA:
KB3033929 - KB3078676 - KB3127673 - KB3055615 - KB3013769 - KB2978367 - KB2967077 - KB2895698 - KB2896328 - KB2852483 - KB2995388
Source: https://support.citrix.com/article/CTX142357
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Apply other Microsoft hotfixes found to address freezing issues on 2012 R2 servers.
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Disable UPM Active Write back on a temporary basis, in order to avoid additional interactions between the VDA and the UPM store multiple times per session/per user in the VDA.
The goal here is to minimize extra CPU or memory usage or additional I/O transactions that may not be necessary if the VDA's are in stable condition. This is transparent to the end users. They will not notice. This recommendation is based on our quick analysis of the UPM logs this afternoon. 7. Disable Profile Streaming momentarily (side effect - it will increase login time but should limit streaming activities of files and folders from the UPM store to the VDA during the ICA Session of the users 8. Disable Antivirus software in the SVDA during tests to isolate a possibility of the Antivirus driver consuming additional CPU resources needed by the application
Problem Cause
A Combination of factors could be causing the issue:
- Missing Microsoft Hotfixes for RDS on 2012 R2 servers being one of them
- Application has a lot of printing calls that can affect performance on the SVDA which could cause momentary freezing
- Application may need the full Explorer.exe
- UPM active writeback could increase the use of CPU and memory resources due to additional I/O transactions occurring several times during an ICA session, competing with those resources used by the application
- The virtual channels used by Citrix Receiver and/or SVDA require a newer version of Receiver and a more updated endpoint device with more RAM and CPU resources
- Citrix API hooks could be using additional CPU resources that are needed by the application
- The application is not fully compatible with 2012 R2 Servers
- The application requires more CPU and as more users are added to the VDA the issue becomes more prevalent
One of the causes above could potentially be the real culprit or a combination of these factors is contributing to this issue.
Issue/Introduction
Some users complain that during ICA session the published Application goes to 'Not Responding' and might make Session Unresponsive toggling back and forth between not responding and running
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