Receiver (4.9|4.10|4.11) installation stuck at setintegritylevel.exe while installing it through Non interactive desktop of a Admin user.

Receiver (4.9|4.10|4.11) installation stuck at setintegritylevel.exe while installing it through Non interactive desktop of a Admin user.

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Article ID: CTX234382

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.

Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

The Symptoms observed are as follows:

1. During installation of RecfWin 4.9/4.10/4.11 from the Non Interactive Desktop of an Admin user, the ICAWebWrapper.msi launches the Setintegritylevel.exe and the installation gets stuck at this point.The installation proceeds to completion after killing this process.

2. The installation works fine in Interactive desktop of the Admin user via installation GUI or CMD.

3. Installation works fine in Non interactive Desktop of system account.

Environment

The above mentioned sample code is provided to you as is with no representations, warranties or conditions of any kind. You may use, modify and distribute it at your own risk. CITRIX DISCLAIMS ALL WARRANTIES WHATSOEVER, EXPRESS, IMPLIED, WRITTEN, ORAL OR STATUTORY, INCLUDING WITHOUT LIMITATION WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NONINFRINGEMENT. Without limiting the generality of the foregoing, you acknowledge and agree that (a) the sample code may exhibit errors, design flaws or other problems, possibly resulting in loss of data or damage to property; (b) it may not be possible to make the sample code fully functional; and (c) Citrix may, without notice or liability to you, cease to make available the current version and/or any future versions of the sample code. In no event should the code be used to support ultra-hazardous activities, including but not limited to life support or blasting activities. NEITHER CITRIX NOR ITS AFFILIATES OR AGENTS WILL BE LIABLE, UNDER BREACH OF CONTRACT OR ANY OTHER THEORY OF LIABILITY, FOR ANY DAMAGES WHATSOEVER ARISING FROM USE OF THE SAMPLE CODE, INCLUDING WITHOUT LIMITATION DIRECT, SPECIAL, INCIDENTAL, PUNITIVE, CONSEQUENTIAL OR OTHER DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. Although the copyright in the code belongs to Citrix, any distribution of the sample code should include only your own standard copyright attribution, and not that of Citrix. You agree to indemnify and defend Citrix against any and all claims arising from your use, modification or distribution of the sample code.

Resolution

Please review the User access rights management and ensure that the user has following rights:

1) Logon as batch
2) Logon as Service

If above steps doesn't help, the only work around available is to install the Receiver under system context using psexec:

reg add HKCU\Software\Sysinternals\PsExec /V EulaAccepted /T REG_DWORD /D 1 /F

psexec -s -i -h CitrixReceiver.exe /EnableCEIP=false /noreboot /silent SELFSERVICEMODE=False ALLOWADDSTORE=N /includeSSON /ENABLE_SSON=Yes /AutoUpdateCheck=disabled ADDLOCAL=ReceiverInside,ICA_Client,SSON,AM,SELFSERVICE,USB,DesktopViewer,Flash,Vd3d,Webhelper

Problem Cause

This issue seems to be due to user's inability to install applications in Non-Interactive desktop, as the installation is successful in the Interactive desktop of the same user and in Non interactive desktop of system account.

Issue/Introduction

Receiver installation stuck at setintegritylevel.exe while installing receiver from Non interactive desktop of an Admin (Receiver installation via Task scheduler). The installation works fine in Interactive desktop using receiver installation GUI and CMD. The receiver installation also works fine with System account in Non interactive desktop.