Getting Duplicate Icons On Launched Desktop
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Article ID: CTX234263
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Description
After launching desktop we can see multiple duplicate icons of published applications in start menu
Environment
Caution! Using Registry Editor incorrectly can cause serious problems that might require you to reinstall your operating system. Citrix cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk. Be sure to back up the registry before you edit it.
Resolution
- If you have machines shared between users under a single generic user account, you might find it useful to delete Self Service generated shortcuts when a user logs off Citrix Receiver or exits the application.
- You can configure this behaviour either by creating the below strings under the HKCU hive for all your users or else have Group Policy do it instead.
- It is possible to create the below strings under HKLM on each machine, but I’ve found it more consistent to do so under HKCU. Either way, make sure to test the behaviour and confirm it works before deploying out.
- To set shortcuts to delete on Receiver logoff and/or exit create string RemoveAppsOnExit and/or RemoveAppsOnLogoff under HKCU\Software\Citrix\Dazzle.
- To manage the behavior using Group Policy enable the Manage App Shortcut policy, part of the Receiver ADMX files that can be downloaded from Citrix.
- Navigate to Computer Configuration -> Policies -> Administrative Templates -> Citrix Receiver -> SelfService -> Manage App Shortcut.
- Enter a value under Startmenu Directory and Destktop Directory. Click OK.
- Select remove apps on logof
Problem Cause
If you have machines shared between users under a single generic user account, you might find it useful to delete Self Service generated shortcuts when a user logs off Citrix Receiver or exits the application. If we do not configure this correctly we see the duplicate icons
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