Plugin installation issue, asking access to Windows Firewall while connecting

Plugin installation issue, asking access to Windows Firewall while connecting

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Article ID: CTX234124

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Updated On:

Description

When installing the Citrix NetScaler PlugIn with the delivered MSI package manually on a Windows10 device, there is a firewall window which requests to make changes. This appears every time user tries to connect to the VPN.

Allowing the Gateway plugin under Windows Firewall cannot be done with user privileges and if you close this window some firewall settings regarding NetScaler are not correctly implemented and when launching next time the popup may appear or you may face issues while connecting to Citrix Gateway. 

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If the popup is appearing all the time your system may not have Citrix Access Gateway as an allowed application under the Windows Firewall, which is a must have requirement.

Resolution

The issue is with the machine as the Windows firewall rules are not getting created under the allowed application. We need to allow the Gateway plugin in the Antivirus or the application(system policy/GPO) which is blocking the same.


Problem Cause

Antivirus or some other application is blocking the NetScaler Gateway from listing the application plugin in the Windows firewall under "Allowed applications".

You might have to install the Plugin with admin rights and have the Windows Firewall allow the plugin to register itself under allowed applications. You can verify this by checking under "Control Panel\All Control Panel Items\Windows Firewall\Allowed apps". It should have Gateway plugin allowed as shown in the following figure:

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Issue/Introduction

Whenever a user tries to connect to the Citrix Gateway VPN solution, he may receive an error stating "Windows Firewall has blocked some features of this app"