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Article ID: CTX234089
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Description
Currently running XenApp 6.5 hotfix rollup 7 and has observed BSOD at least once a day in the XenApp 6.5 worker servers.
The most recent bugcheck is a 0x000000ab SESSION_HAS_VALID_POOL_ON_EXIT. ntoskrnl.exe ntoskrnl.exe+3e515f fffff800`02218000 fffff800`027fb000 0x005e3000 0x5aa1f203 3/8/2018 10:31:31 PM Microsoft® Windows® Operating System NT Kernel & System 6.1.7601.24059 (win7sp1_ldr_escrow.180308-1637) Microsoft Corporation C:\Windows\system32\ntoskrnl.exe
The server 2008 R2 OS is up to date with the exception of two optional updates. Event logs do not have any errors just prior to the crashes.
This issue is also observed in later version of XenApp 7.15 as well.
Resolution
Uninstalling the Microsoft KB4088875 stops the BSOD from occurring
OR
Follow this sequence for proper sequence of installation:
Before installing KB4088875, this KB must be installed:
KB4099950 After installing KB4088875 this KB must be installed:
KB4100480After installing KB4088875 this KB must be installed:
KB4099467 to prevent the "SESSION_HAS_VALID_POOL_ON_EXIT (ab)" BSOD
Problem Cause
Installation of KB4088875 on March 14th, 2018 caused the BSOD: "SESSION_HAS_VALID_POOL_ON_EXIT (ab)"
Other facts to be aware:
Before installing KB4088875, this KB must be installed:
KB4099950 After installing KB4088875 this KB must be installed:
KB4100480After installing KB4088875 this KB must be installed:
KB4099467
Issue/Introduction
After installing Windows updates on March 14th, 2018 end users ar facing BSOD with error: "SESSION_HAS_VALID_POOL_ON_EXIT (ab)"