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Article ID: CTX233939
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Description
Unable to launch Applications while using XenApp Essentials.
Error: Could not start App, there was a problem contacting the store. Cannot RDP to the VDA machine. Error while RDP: "The remote sessions was disconnected because there are no Remote Desktop License servers available to provide a license. Please contact the server administrator."
Resolution
You do not have an existing RDS licensing server, and you have purchased RDS User CALs from XenApp Essentials by selecting the option "Purchase now for $6.25 per user per month" while configuring XenApp Essentials(as mentioned in the following screenshot; reference:
"New purchasing options to simplify bring your own (BYO) RDS CAL:" section of citrix blog: https://www.citrix.com/blogs/2017/11/10/whats-new-in-xenapp-essentials-nov-2017):

Then follow these steps:
- Spin a new machine with Microsoft Remote Desktop licensing role installed on it.
- Apply the following group policies
1. Set the Remote Desktop licensing mode Group Policy setting (Value: Enabled)
2. Use the specified Remote Desktop license servers: (Value: Enabled; and the address of the license server to be used)
Location:
Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Licensing and can be configured by using either Local Group Policy Editor or the Group Policy Management Console (GPMC).
Note that the Group Policy setting will take precedence over the setting configured in Remote Desktop Session Host Configuration.
Note:These policies should be applied from either Azure ADDC or the Domain Controller. You can also apply these policies using local group policy editor on each VDA machine.
Problem Cause
The RDS license server was not configured and the required RDS CAL policies were not applied.