Voice call over AVAYA Softphone may have a choppy voice or humming sound after multiple users login, while using Receiver for Windows 

Voice call over AVAYA Softphone may have a choppy voice or humming sound after multiple users login, while using Receiver for Windows 

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Article ID: CTX233747

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Updated On:

Description

This article is intended for Citrix administrators and technical teams only.
Non-admin users must contact their company’s Help Desk/IT support team and can refer to CTX297149 for more information.

You may hear choppy voice or humming sound when  multiple users login and do a voice call through a ICA session, while using Receiver for Windows

Resolution

1. Enable the Audio policies as documented in this article: 

Ensure Audio quality is set to Medium in Citrix audio policy 

2. Added following in default.ica at C:\inetpub\wwwroot\Citrix\Store\App_Data\default.ica 

; This is to enable Real-Time Transport 

EnableRtpAudio=true 

; This is to Allow Real-Time Transport Through gateway 

EnableUDPThroughGateway=true 

; This is to set audio quality to Medium 

AudioBandwidthLimit=1

; UDP Port range 

RtpAudioLowestPort=16500 

RtpAudioHighestPort=16509 

3. Did a iisreset using following command on Storefront server < elevated command prompt> 

    iireset 


4. Set HDX Adaptive Transport to "Preferred" in Citrix Policies 


5. Do a group policy update on VDA hosting Avaya softphone application 

gpupdate /force 


6. The ICA file should have following entries: 

[Avaya one-X Communi] 

Address=XXX.XXX.XXX.XXX:1494 

AudioBandwidthLimit=1

AutologonAllowed=ON 

BrowserProtocol=HTTPonTCP 

CGPAddress=*:2598 

ClearPassword=XXXXXXXXXXX 

ClientAudio=On 

DesiredColor=X

DesiredHRES=0 

DesiredVRES=0 

Domain=\<Hexa Decimal>

DoNotUseDefaultCSL=On 

EnableRtpAudio=true 

EnableUDPThroughGateway=true 

FontSmoothingType=0 

HDXoverUDP=Preferred 

InitialProgram=#Avaya one-X Communi 

Launcher=WI 

LaunchReference=<Hexa Decimal GUID>

LocHttpBrowserAddress=! 

LogonTicket=<Hexa Decimal GUID>

LogonTicketType=CTXS1 

LongCommandLine= 

LPWD=687 

NRWD=656 

ProxyTimeout=30000 

ProxyType=Auto 

RtpAudioHighestPort=16509 

RtpAudioLowestPort=16500 

SessionsharingKey=<Hexa Decimal GUID>

SFRAllowed=Off 

SSLEnable=Off 

startSCD=XXXXXXXXXX

Title=Avaya one-X Communicator 

TransportDriver=TCP/IP 

TRWD=0 

TWIMode=On 

UDPCGPPort=XXX.XXX.XXX.XXX:2598 

UDPICAPort=XXX.XXX.XXX.XX:1494 

WinStationDriver=ICA 3.0 

7. Test Avaya softphone, by calling an extension or direct phone number


Problem Cause

The issue is caused by non-optimal audio configuration where audio quality was set to "High" and HDX adaptive transport is disabled.
 

Additional Information

By default, adaptive transport is disabled (Off) and TCP is always used. Enabling HDX adaptive transport helps.

Adaptive transport is faster, more scalable, improves application interactivity, and is more interactive on challenging long-haul WAN and internet connections.  It maintains high server scalability and efficient use of bandwidth. By using adaptive transport, ICA virtual channels automatically respond to changing network conditions. They intelligently switch the underlying protocol between the new Citrix protocol called Enlightened Data Transport (EDT) and TCP to deliver the best performance.